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Message: "Unable to Create a Snapshot of <Name of Virtual Machine>"

Summary:

During a Hyper-V backup, the following error appears.

Unable to create a snapshot of <Name of Virtual Machine>.

Cause:

Carbonite Safe Server Backup, like most Windows backup applications, relies heavily upon the Volume Shadowcopy Services (VSS) in order to take backups.

This error appears when Volume Shadowcopy Services are unable to take a snapshot of one or more Virtual Machines. It covers any and all cases in which a snapshot cannot be created.

Most commonly, this occurs when the Backup (volume checkpoint) option is not selected in Integration Services for the VM(s) in question.

This article applies to:

Carbonite Plans Products Platforms
Power and Ultimate (Not sure?) Carbonite Safe Server Backup (Not sure?) Windows

Solution:

Please note that this is a generalized error that covers any and all cases in which VSS fails to take a snapshot or checkpoint of one or more VMs involved in the backup. A few known causes can be found below.

Like all VSS problems, this behavior should be thoroughly investigated by the system administrator responsible for the server.

Potential Issue #1: Backup (volume checkpoint) is disabled

Each VM must have the Backup (volume checkpoint) option checkmarked in Integration Services. A snapshot cannot be made if this option is not selected. This is the most common cause for this error.

Backup (volume checkpoint)
In some rare cases, we have found it necessary to remove the checkmark, apply changes, add the checkmark, and apply changes again.

Potential Issue #2: VSS requirements are not met

Carbonite Safe Server Backup, like nearly all Windows backups, has several requirements related to VSS. This includes Hyper-V backups.

Please ensure that all CSSB system requirements are met, especially those related to VSS (Volume Shadowcopy Services). VSS requirements are outlined in the System Requirements section of the User Guide.

In particular, ensure that:

  • VSS is enabled.
  • There is VSS shadowstorage configured for all drives that contain data selected for backup, with at least 10% space allocated to each.
  • Any drive that contains VSS shadowstorage has sufficient space necessary to store snapshots. Free space should be equal to or higher than the amount allocated for shadowstorage.

More information on how to manage Shadowstorage can be found in this article.

Potential Issue #3: Unsupported disks are attached to a Windows Server 2008/2008 R2 Hyper-V host

Hard disks with a sector size of 4096 are not supported by Windows Server 2008 or Windows Server 2008 R2. Hyper-V backups are more susceptible than any other backup type.

Simply attaching a "4k drive" to a system can be enough to cause Hyper-V backup failures, even if the drive is not involved in the backup in any way.

You may refer to Microsoft's KB article on 4k sector hard drives for more information.

Please ensure that your hard disks and Windows version are compatible. If an incompatible drive is attached, remove it. A reboot is frequently necessary to bring VSS back to a healthy state.

Further Troubleshooting

Further troubleshooting is beyond the scope of this article. Investigative troubleshooting techniques should be utilized to determine the root cause of snapshot creation failure.

The Windows System Event Logs usually contain references to snapshot failures and can direct the investigation. It is also worth ensuring that the system is fully up to date with Windows Updates.

Please refer to this Microsoft article for more information on general VSS event IDs.

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